spamassassin deleting spam

Technical support for webhosting Resellers, and questions which directly relate to their services.

Moderator: Admins

Post Reply
Luke
newbie
Posts: 14
Joined: Mon Oct 09, 2006 3:23 pm
Contact:

spamassassin deleting spam

Post by Luke » Thu Oct 12, 2006 9:46 am

When activating spamassassin I initally chose the option to delete all mail identified as spam ("To simply have the server DELETE and NOT deliver emails that are tagged as spam by SpamAssassin, click here now"). I subsequently decided that this was not such a great idea and clicked on the "Disable Spam Box" option and configured the rewrite_header subject field to identify tagged mail.

I was getting tons of spam before this sequence and now I'm getting little - no emails are tagged with the new subject header. My concern is that the "Disable Spam Box" button did not override my earlier choice.

Can anyone answer this for sure? It's really a shame that the Boxtrapper product is such a piece of crap (I configured it but it went into some weird loop and used all the disk space). We use Active Spam Killer (works like Boxtrapper claims to) where I work and it has reduced the SPAM load to near zero.

Thanks!

gands
newbie
Posts: 21
Joined: Thu Jan 19, 2006 1:17 am
Location: Toronto, Canada

Post by gands » Thu Oct 12, 2006 6:52 pm

You can view the spambox folder(s) if you use IMAP. If there's any folder by that name, check it. Spambox is for each POP or IMAP account, so it's not central.

I'd also lower the spam score in Spamassassin to 4.0 instead of the default 5.0.

Luke
newbie
Posts: 14
Joined: Mon Oct 09, 2006 3:23 pm
Contact:

Post by Luke » Fri Oct 13, 2006 9:34 am

my SPAM folder is empty. All appearances are that the SPAM is being deleted because I initially selected that option. How do I reverse that?

As for the 5.0, the instructions say "5.0 is the default setting, and is quite aggressive; it would be suitable for a single-user setup, but if you're an ISP installing SpamAssassin, you should probably set the default to be more conservative, like 8.0 or 10.0". This implies (at least to me) that at the 5.0 setting, valid emails may be improperly tagged as SPAM, which would be unfortunate./ I'd be willing to try it, however, if I could assure that the mail tagged as SPAM gets relabeled and forwarded to me

Sorry to be such a pain - thanks for your help!

Luke Steele

Luke
newbie
Posts: 14
Joined: Mon Oct 09, 2006 3:23 pm
Contact:

Post by Luke » Fri Oct 13, 2006 9:42 am

More information:

Apparently, clicking the "click here" option executes addspamfilter.html, which doesn't seem to be in my tree. I'm assuming it created a filter, though I can't seem to find it in the .spamassassin folder. Any ideas?

Luke
newbie
Posts: 14
Joined: Mon Oct 09, 2006 3:23 pm
Contact:

Post by Luke » Fri Oct 13, 2006 11:07 am

More info:

Based on the infor at http://www.spamassassin.org/, I found similar text in a file named ".filter" in the creedmoornc root directory. I have renamed this file to see if the symptoms change. Does this sound familiar to anyone?

Does addspamfilter.html create this file?

Luke

Post Reply