Spamassassin problem

Technical support for webhosting Resellers, and questions which directly relate to their services.

Moderator: Admins

Post Reply
gands
newbie
Posts: 21
Joined: Thu Jan 19, 2006 1:17 am
Location: Toronto, Canada

Spamassassin problem

Post by gands » Sat Jan 02, 2010 10:18 pm

Happy New Year!

Since January 1, 2010, Spamassassin has been tagging practically every email as spam. It tags everything as having a "date grossly in the future" and gives a score of 3.4. I googled this problem and found this at the cpanel forums:
http://forums.cpanel.net/f43/spamassass ... 42725.html

Is there a fix for prioritycolo's servers soon?

Thanks.

porcupine
Site Admin
Posts: 669
Joined: Wed Jun 12, 2002 5:57 pm
Location: Toronto, Ontario
Contact:

Re: Spamassassin problem

Post by porcupine » Sat Jan 02, 2010 10:52 pm

Hey Gands,

When is the same time you saw this recur?

As noted in the CPanel thread, this was fixed by the autoupdate, so it should have been resolved last night (immediately following CPanels mailing to all customers, where they indicated anyone running autoupdates [all reseller servers] were already/automatically being patched up).
Myles Loosley-Millman
Priority Colo Inc.
myles@prioritycolo.com
http://www.prioritycolo.com

gands
newbie
Posts: 21
Joined: Thu Jan 19, 2006 1:17 am
Location: Toronto, Canada

Re: Spamassassin problem

Post by gands » Sat Jan 02, 2010 11:18 pm

It's been steady since Jan 1 (Friday). I've checked just now and found some from this evening. I get regular email from a mailing list and they're tagged as such.

Can you manually update cpanel again?

porcupine
Site Admin
Posts: 669
Joined: Wed Jun 12, 2002 5:57 pm
Location: Toronto, Ontario
Contact:

Re: Spamassassin problem

Post by porcupine » Sun Jan 03, 2010 5:32 pm

Hey Gands,

I tried one better, and ran the fix across every server in the reseller/hosting lot. Unfortunately it looks like they had all, already run the updates (as CPanel had indicated). That either indicates, the messages you're getting have been queued for a unusually long time, something didn't take, or theres a bug in the update:

Code: Select all

# /scripts/autorepair spamd_y2010_fix
Requesting script ... Done
Auto Repair is running...spamd_y2010_fix: version 1.6
spamd_y2010_fix: spamassassin rules have already been updated.
...Auto Repair is done.
Please forward the next SA trapped email (thats marked with this condition) to admin@prioritycolo.com, along with your resource number, so I can check into the issue at hand, in more depth.
Myles Loosley-Millman
Priority Colo Inc.
myles@prioritycolo.com
http://www.prioritycolo.com

gands
newbie
Posts: 21
Joined: Thu Jan 19, 2006 1:17 am
Location: Toronto, Canada

Re: Spamassassin problem

Post by gands » Sun Jan 03, 2010 9:55 pm

It appears to be fixed now. I no longer get an unusually high number of SA false positives. And the "grossly in future" tag is not in the ones that are false positives. If there are any more that are improperly tagged, I'll forward them.

Thanks Myles.

porcupine
Site Admin
Posts: 669
Joined: Wed Jun 12, 2002 5:57 pm
Location: Toronto, Ontario
Contact:

Re: Spamassassin problem

Post by porcupine » Mon Jan 04, 2010 2:15 am

Good stuff, glad to hear :)
Myles Loosley-Millman
Priority Colo Inc.
myles@prioritycolo.com
http://www.prioritycolo.com

Post Reply